Linux下wordpress自动升级

大家一定对Linux下的权限又爱又恨吧,wordpress总是因为这些会不能正常升级,下面总结一个方法便于自动升级,其实懂一点的人一看就知道啦,特此记录。
1、修改WordPress目录由Apache服务器的用户名所有。参考命令如下:
chown -R apache *
2、修改所有文件权限为777。参考命令如下:
chmod -R 777 *
3、关闭所有插件
4、点击升级,成功后,开启重建
5、恢复wordpress为admin所有,文件权限为775。
需要设置文件权限为777的文件夹
cache
wp-content
archivers

reeoo.com - web design inspiration

47条评论

  1. 深圳装修说道:

    博主高手啊 我表示崇拜

  2. dobila说道:

    不错,学习了。

  3. 那些事儿说道:

    飘过~顶了!

  4. 如何化妆说道:

    拜访一下你的博客,支持一下你

    同时欢迎来我的化妆博客www.wxhzs.com看看啊,互相学习下

  5. 小五说道:

    我后台点击一次 记忆可以ok

  6. vaman说道:

    对这个所属权限实在是搞不明白啊

  7. 灰常记忆说道:

    :!!!: 俺也记录下 备用

  8. SB说道:

    我喜欢windows,不用linux

  9. 酷博说道:

    自动升级我表示压力很大,我改的源码比较多,自动升级就玩完了 :kbz:

  10. 蓝色离子说道:

    为什么要自动升级,,出现错误就玩完了!

  11. dvd说道:

    这个可以试一下

  12. 尘色记忆说道:

    之前自己架设VPS的时候也 遇到过 确定是文件夹 权限问题 。

  13. 陈连龙说道:

    咱告别wordpress了

  14. liveme说道:

    还是想不太明白,在linux系统下应该也是一样的吧

  15. Godor说道:

    申请友情链接
    网址:http://www.godor.cn
    网站名称:顾道博客
    :gl:

  16. 罗伊说道:

    我就是linux的vps啊,可以不改什么自动升级的。

  17. 泥菩萨说道:

    人气好旺。借风水旺地旺一下自己

  18. 爱惜说道:

    我现在考虑我的博客要不要升级。本人还是3.0+。。。想直接后台升级到最新版本。但又怕出问题 🙄

  19. xizi说道:

    用过呵呵,空间服务器上就要求改权限才能做升级

发表评论

电子邮件地址不会被公开。 必填项已用*标注